Fandom

Gnome Music Player Client

Installation Source

144pages on
this wiki
Add New Page
Talk0 Share

Ad blocker interference detected!


Wikia is a free-to-use site that makes money from advertising. We have a modified experience for viewers using ad blockers

Wikia is not accessible if you’ve made further modifications. Remove the custom ad blocker rule(s) and the page will load as expected.

If you installed gmpc from your distro's repository, uninstall gmpc and libmpd first

To intstall gmpc you need the following programs to be installed:

* gcc compiler
   * libtool
   * intltool Version 0.21 or higher
   * glib
   * libcurl
   * libsoup
   * gobject
   * gtk+-2.0
   * gmodule
   * libglade
   * gthreads
   * libmpd
   * gob 2.0
   * hicolor theme


Install libmpd Edit

Get a copy of libmpd and extract it:

tar -zxf libmpd-0.18.0.tar.gz

Enter the directory:

cd libmpd-0.18.0/

Run the needed autotools:

./configure

Watch the output carefully for errors. If it was succesfull build libmpd:

make

And install it (you might want to run this as root):

make install


Install gmpc Edit

Get a copy of gmpc and extract it:

tar -zxf gmpc-0.18.0.tar.gz

Enter the directory:

cd gmpc-0.18.0/

Run the needed autotools:

./configure

If it complains about not finding libmpd, make sure you have it installed and pkg-config can find it. For example if you installed libmpd in /opt and pkg-config cannot find it try telling it where to look by setting the following environment variable:

export PKG_CONFIG_PATH=/opt/lib/pkgconfig/

and rerun configure

If it was succesfull you can build gmpc

make

And install it (you might want to run this as root):

make install

Don't forget this step, gmpc won't run without this step.

If everything went smooth, you should be able to run gmpc.


Install a gmpc plugin Edit

For this example I use the coveramazon plugin, but it applies for all plugins:

Get a copy of the plugin and extract it:

tar -zxf gmpc-coveramazon-0.18.0.tar.gz

Enter the directory:

cd gmpc-coveramazon-0.18.0/

Run the needed autotools:

./configure

If it complains about not finding libmpd or gmpc, make sure you have it installed and pkg-config can find it. For example if you installed libmpd in /opt and pkg-config cannot find it try telling it where to look by setting the following environment variable:

export PKG_CONFIG_PATH=/opt/lib/pkgconfig/

and rerun autogen.sh

If it was succesfull you can build gmpc-coveramazon

make

And install it (you might want to run this as root):

make install

If everything went smooth, after restarting gmpc, you should be able to see this plugin in gmpc.

Also on Fandom

Random Wiki